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Project 
Opdracht 
Voor dit project gaan we gegevens uit XML en JSON (en eventueel YAML) bestanden lezen en bewerkingen 

op uitvoeren. We gaan een website maken met meerdere afspeellijsten met muzieknummers. Je kan ervoor 

kiezen om de muzieknummers te uploaden en te kunnen afspelen. 

Dit project dient in tweetallen (of waar nodig drietallen) te worden uitgevoerd. Jullie kiezen zelf met wie je 

wil samenwerken en geeft vervolgens de groep aan bij de docent. 

Er zal een methodiek genaamd Scrum worden gebruikt tijdens dit project. In deze vorm zullen de volgende 

onderdelen aan bod komen: 

• Product Backlog Item (PBI) 

o Per groep bepaal je welke onderdelen er dienen te worden uitgevoerd om het project 

succesvol te maken. Dit kan zo gedetailleerd als jullie zelf willen, zolang er minimaal maar 10 

items zijn. Denk hier bijvoorbeeld aan: web project opstarten, song class maken, CSS stijl 

zoeken, CSS stijl toevoegen, pagina om de muzieknummers weer te geven, enzovoort. Deze 

items zet je in een e-mail, met als titel Product Backlog Items, en stuurt deze naar je docent. 

• Sprint Backlog Item 

o Aan het begin van de sprint overleg je met elkaar welke Product Backlog Items jullie gaan 

uitvoeren in de aankomende sprint en welke jullie dus aan het einde van deze sprint denken 

af te hebben. Deze items zet je in een e-mail, met als titel Sprint x Backlog Items (waarbij de 

x het nummer is van de sprint), en stuurt deze naar je docent. 

• Sprint 

o We zullen tijdens dit project sprints hanteren van twee weken. In totaal zullen we 4 sprints 

uitvoeren voordat het project klaar dient te zijn. 

• Sprint Review 

o Aan het einde van de sprint kijk je terug en geef je antwoord op de volgende vragen: 

▪ Wat is er goed gegaan? 

▪ Wat kon er beter? 

▪ Wat hebben we nodig om verder te kunnen? 

De antwoorden op deze vragen zet je in een e-mail, met als titel Sprint x Review (waarbij de 

x het nummer is van de sprint), en stuurt deze naar je docent. 

Criteria 
De volgende criteria gelden voor dit project: 

• Je website dient opgezet te zijn zoals beschreven in het stappenplan hieronder, waar dus gebruik 

wordt gemaakt van een webapplicatie in C#; 

• Je dient een mooie webapplicatie op te leveren die naar behoren werkt. Dit betekent dat je een 

eigen stijl moet hebben voor je webapplicatie; 

• Er moet zowel een mogelijkheid voor XML als voor JSON (en voor drietallen ook YAML) inzitten; 

• Er dient een eigen toevoeging / feature op te zijn genomen die jullie hebben bedacht / gekozen; 

Beoordeling 
Je wordt uiteindelijk beoordeeld op de webapplicatie, de individuele bijdrage, jullie samenwerking en het 

toepassen van Scrum en de bij te houden documentatie. 

Tips 

• Gebruik een website zoals Azure DevOps of Trello voor het bijhouden van Backlog Items; 

• Gebruik voor het gezamenlijk ontwikkelen aan een project zoiets als GitHub of Subversion; 
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Project aanmaken in Visual Studio 
• Open Visual Studio 2022 

• Kies in het hoofdmenu de optie File > New > Project … 

• Kies in het dialoogvenster Add a new project de optie ASP.NET Core Web App. 

 

 
 

• Sla dit project op onder de naam MusicPlaylist in een map naar keuze. Klik op de knop Next. 

• In het scherm Additional information hoeft er niets veranderd te worden. Klik op de knop Create. 
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• Een basis project is nu aangemaakt. Open en bekijk de Solution Explorer. In dit project zijn 

verschillende functionaliteiten standaard al opgenomen, denk o.a. aan (Twitter) Bootstrap, jQuery 

en jQuery Validation. 

 

(Twitter) Bootstrap is een collectie van tools voor het creëren van websites en (web)applicaties. 

Bootstrap bevat html- en css-based design templates voor forms, buttons, navigation en andere 

interfacecomponenten. 

 

• Klik rechts op het project en kies Add > New Folder. Noem de nieuwe folder Code. 

• Klik rechts op het project en kies Add > New Folder. Noem de nieuwe folder Data. 
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XML bestand aanmaken 
Voeg een nieuw XML bestand toe door rechts te klikken op de Data folder en te kiezen voor Add → New 

Item. Vervolgens kies je voor Visual C# → ASP.NET Core → Data en dan XML File. Vergeet je XML bestand 

niet een goede naam te geven, bijvoorbeeld Playlist.xml. Klik vervolgens op Add. 

 

 

 

In het XML bestand gaan we een structuur aanmaken waar we voor onze playlist onze muzieknummers in op 

kunnen nemen. Een aantal zaken zijn noodzakelijk voor een XML bestand, namelijk: 

• De eerste regel geeft de XML tag. In deze tag wordt XML informatie opgenomen; 

• De tweede regel geeft de root tag aan. Deze is benodigd om onze muzieknummers in op te slaan; 

Typ de onderstaande code over in het aangemaakte XML bestand. 
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Muzieknummers weergeven in een pagina 
Nieuwe pagina toevoegen 
We gaan nu een webpagina aanmaken waarin we de muzieknummers zichtbaar maken. Hiervoor moeten we 

de inhoud van het XML bestand inlezen en in HTML zichtbaar maken. Je gaat hier gebruik maken van een 

Razor Page en een Class. 

• Klik rechts op de Code folder en kies Add > New Folder. Noem de nieuwe folder XML. 

• Voeg een nieuwe Class toe door rechts te klikken op de nieuw gemaakte XML folder en te kiezen 

voor Add → Class…. Geef de class de naam SongMethods. 

• Klik rechts op de Pages folder en kies Add > New Folder. Noem de nieuwe folder XML. 

• Voeg een nieuwe Razor Page (cshtml) toe door rechts te klikken op de nieuw gemaakte XML folder 

en te kiezen voor Add → Razor Page…. Kies voor Razor Page – Empty en klik op Add. Geef de 

nieuwe Razor Page de naam Index.cshtml. Klik vervolgens op Add. 

Bestanden eindigend op .cshtml staan voor de combinatie C-Sharp (C#) en HTML. Je kunt deze bestanden 

vergelijken met de extensie .phtml bij PHP. In cshtml bestanden kun je eenvoudig C# combineren met HTML, 

waarbij C# altijd begint met een @ symbool of als het een geheel code blok betreft met @{ }. 

De structuur in de Solution Explorer ziet er nu als volgt uit: 
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De class SongMethods voorzien van code 

• Maak in de class SongMethods een methode GetAllSongs(string file) aan met de volgende code. 

 

Je ziet dat Visual Studio twee fouten geeft door code met rood te onderstrepen. Eén van die fouten wordt 

veroorzaakt doordat het resultaat van de methode een DataSet is. Het DataSet type wordt nog niet herkend. 

De code voor het uitlezen van een XML bestand zit binnen een bepaalde library in C#. Om deze code te 

kunnen gebruiken moeten we ons bestand laten weten dat we die library willen gaan gebruiken. In dit geval 

dienen we de library System.Data in te laden, daarom voegen we bovenaan de pagina de volgende code toe: 

 

De class DataSet zit dus in de library System.Data. Eén van de foutmeldingen verdwijnt nu, de andere 

foutmelding zullen we hierna gaan oplossen.  
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Het XML bestand inlezen 
De eerste class waar we een instantie van nodig hebben is een DataSet. Dit is te vergelijken met een 

database. Binnen de DataSet maken we een DataTable (een tabel) en daarbinnen zitten DataColumns 

(kolommen). Na het inlezen van het XML bestand zitten er ook DataRows (regels) in deze DataTable. In 

iedere constructor van deze objecten geven we de naam mee van de overeenkomende XML tag zodat we 

straks bij het inlezen daar profijt van hebben. 

• Voeg nu onderstaande code toe aan de methode GetAllSongs(string file). Met deze code wordt een 

instantie van een DataSet, een DataTable en meerdere DataColumns gemaakt. Let hierbij op de 

parameter van de constructor van deze classes en vergelijk deze met de tags in het XML bestand. 

 

Na het maken van alle objecten (instanties van de classes DataSet, DataTable, DataColumns) moeten al deze 

objecten goed aan elkaar gekoppeld worden. De DataColumns moeten allemaal aan de collectie 

DataTable.Columns worden toegevoegd. De DataTable zelf moet aan de collectie DataSet.Tables worden 

toegevoegd. Al deze koppelacties gaan met de standaard Add methode. Zorg dat de nieuwe code wordt 

toegevoegd wordt aan de methode GetAllSongs(string file). 
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De laatste stap is het inlezen van de data (lees: muzieknummers) uit het XML bestand en in deze in de 

DataSet zetten. Dit gebeurt middels de ReadXml methode. Voeg de volgende code toe aan de 

GetAllSongs(string file) methode. 

 

Let er wel op dat de webapplicatie zelf niet weet waar het XML bestand staat. De webserver van Visual 

Studio is standaard een IIS-express variant en start ergens bij de Program Files map. Dit is ook de plek waar 

de webapplicatie zal gaan zoeken naar het XML bestand, maar deze zal niet gevonden worden. Om de juiste 

plek van het aangemaakte XML bestand aan te geven dienen we gebruik te maken van de volgende code: 

Environment.CurrentDirectory. Deze variabele geeft het pad naar de huidige directory aan. De zojuist 

toegevoegde ReadXml code dient dus veranderd te worden inclusief deze Environment.CurrentDirectory: 

 

Als laatste stap voor dit onderdeel dienen we een variabele terug te geven (returnen), zoals we hebben 

aangegeven in de structuur van de GetAllSongs(string file) methode. Dit zullen we doen door als laatste code 

regel in GetAllSongs(string file) de volgende code op te nemen: 

 

Hiermee verdwijnt ook direct de foutmelding die we nog hadden bij de GetAllSongs(string file) methode. 
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Inhoud XML bestand zichtbaar maken in HTML 
Na het inlezen van het XML bestand moet de data zichtbaar worden in een cshtml pagina. Dit doe je door 

gebruik te maken van de class SongMethods in het bestand \Pages\XML\Index.cshtml. 

• Open het bestand \Pages\XML\Index.cshtml. 

• Voeg bovenin het bestand de System.Data en Code.XML libraries toe: 

 

Let hierbij op dat deze code moet worden voorafgegaan door @ omdat het C#-code is. @ wordt in een 

cshtml bestand een Razor tag genoemd. 

De Code.XML library hebben we nodig omdat onze SongMethods class hierin staat. 

• Voeg nu in het @{ } code blok de volgende code toe: 

 

Ook hier wordt gebruik gemaakt van Razor. In dit geval is het een Razor blok, omdat er meerdere C# 

statements achter elkaar worden uitgevoerd. 

Er wordt op regel 10 gebruik gemaakt van een @ voor het XML bestand om ervoor te zorgen dat de \ goed 

wordt geïnterpreteerd. Neem je de @ niet op dan kan je het pad alleen correct schrijven met dubbele \\, dus 

dan zou het pad worden \\Data\\Playlist.xml. 

In regel 9 wordt een instantie van de class SongMethods gemaakt. Dit object heet xmlSongMethods. 

In regel 10 wordt een deel van het pad van het XML bestand in de variabele xmlFile gezet. 

In regel 11 wordt de methode GetAllSongs(string file) in het object xmlSongMethods uitgevoerd. In deze 

methode wordt een DataSet opgebouwd en gevuld met de data uit het XML bestand. Daarna geeft deze 

methode de gevulde Dataset terug. In regel 11 wordt die gevulde DataSet in de variabele xmlDataSet gezet. 
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Het uitlezen van de DataSet kan door middel van een foreach loop die door alle DataRows (lees: 

muzieknummers) loopt die in de DataTable zitten. 

 

Deze foreach loop gaat rij voor rij door de tabel met de naam song heen en zet de gevonden rij telkens in 

een variabele genaamd drSong, deze is van het type DataRow. 

De DataRow drSong kan uitgelezen worden als een soort Array. Gebruik hiervoor de blokhaken. 

HTML en C# code mag door elkaar gebruikt worden (met Razor tags). Hieronder zie je een voorbeeld: 
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Voordat we de webapplicatie kunnen starten dienen we de \Pages\XML\Index.cshtml pagina beschikbaar te 

maken in de menu navigatie. In de \Pages\Shared\ folder staat een bestand genaamd _Layout.cshtml, hier 

wordt de layout van de webapplicatie opgebouwd. 

• Open het bestand \Pages\Shared\_Layout.cshtml. 

• Kopieer één van de menu items en pas deze code aan voor de XML Index pagina: 

 

• Start de webapplicatie en klik op het XML menu item. De data (lees: muzieknummers) uit het XML 

bestand wordt nu zichtbaar gemaakt in de webpagina. 
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Een nieuw muzieknummer toevoegen aan de playlist 
Aanpassingen op de bestaande webapplicatie 
Er dient een aanpassing te worden gemaakt in de SongMethods class. 

• Verplaats de regel DataSet ds = new DataSet("playlist"); in de methode GetAllSongs(string file) naar 

de bovenkant van de class (buiten de methode GetAllSongs(string file)). 

 

Deze wijziging moet je toepassen omdat het object ds ook in andere methodes binnen deze class moet 

kunnen worden gebruikt. Door deze variabele uit de methode GetAllSongs(string file) te halen maak je de 

variabele globaal. In de oude situatie kon je het object alleen binnen de methode GetAllSongs(string file) 

gebruiken. 

• Maak een nieuwe methode in de class SongMethods aan met de naam GetEmptyDataRow(). 

 

In de regel DataRow dr = ds.Tables["song"].NewRow(); wordt een nieuwe DataRow gecreëerd. Deze 

DataRow bevat nog geen gegevens, maar heeft wel dezelfde structuur als een DataRow in de DataTable met 

de naam song. Deze methode zullen we straks nodig zijn. 

• Maak een nieuwe methode in de class SongMethods aan met de naam CreateSong(…). Deze 

methode heeft twee parameters. 

 

De eerste parameter bij de CreateSong methode is van het type DataRow. In deze DataRow zullen de 

gegevens van het nieuwe muzieknummer komen te staan. De tweede parameter is van het type string en 

hier zal het pad naar het XML bestand komen te staan. 

In de regel ds.Tables["song"].Rows.Add(dr); wordt de DataRow dr in de collectie Rows van de DataTable 

met de naam song toegevoegd. Tot slot worden de gegevens uit de DataSet in het XML bestand 

weggeschreven (lees: overschreven).  
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Nieuwe pagina toevoegen 

• Maak een nieuwe cshtml pagina in de folder \Pages\XML\ en noem deze pagina Create.cshtml. Zorg 

ervoor dat je via deze pagina een nieuw muzieknummer kunt toevoegen. Hieronder zie je hoe zo’n 

webpagina er uit kan zien. Je dient dit HTML formulier dus zelf te coderen. 

 

• Voeg vervolgens bovenin de \Pages\XML\Create.cshtml pagina de volgende code toe: 
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• Voeg nu het volgende stuk code toe aan het C# code blok op deze pagina. 

 

De regel if (HttpMethods.IsPost(Request.Method)) controleert of er een POST verstuurd is, oftewel 

wanneer een formulier met de method POST verstuurd wordt. 

In de regel drSong[0] = Request.Form["id"]; wordt aan de eerste cel van de nieuwe DataRow een waarde 

toegevoegd. Deze waarde is een POST uit het formulier (in dit geval uit een textbox met name="id"). 

Request.Form["id"]  is te vergelijken met $_POST["id"]  in PHP. In de regels 17 t/m 22 wordt de DataRow dus 

gevuld met de waardes die zijn ingevuld in het formulier. 

Op regel 24 wordt de methode CreateSong(…) in het object xmlSongMethods uitgevoerd met de parameters 

drSong en xmlFile. De nieuwe DataRow wordt in de DataSet gezet en daarna opgeslagen in het XML bestand. 

In regel 25 geef je aan de server de opdracht de pagina /XML/Index naar de client (jouw computer) te sturen.  

Request en Response 
In de code die je zojuist hebt toegevoegd heb je het Request- en het Responseobject gebruikt. Dit zijn 

objecten binnen het .NET framework, maar wanneer gebruik je deze objecten nu precies? 

Een request is een aanvraag die een client (b.v. jouw computer) naar een server stuurt. In ons geval wordt 

een post request met data uit een form naar de server gestuurd. Binnen de server kan iets met die data 

worden gedaan (met server-side C#- of PHP-code). Een post is dus een voorbeeld van een request. 

Een response is een reactie van een server (bijvoorbeeld op een request van een client). De regel 

Response.Redirect("/XML/Index"); is een request, maar de client vraagt daarin de server een response, 

namelijk: stuur de pagina /XML/Index naar de client. Op de client wordt deze pagina dan getoond. Een 

omleiding naar een andere webpagina (redirecten) naar de client is dus een voorbeeld van een response. 
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Een muzieknummer verwijderen uit de playlist 
Nieuwe pagina toevoegen 

• Maak een nieuwe cshtml pagina in de folder \Pages\XML\ en noem deze pagina Delete.cshtml. Zorg 

ervoor dat je via deze pagina een muzieknummer kunt verwijderen. Hieronder zie je hoe zo’n 

webpagina er uit kan zien. Je dient dit HTML formulier dus zelf te coderen. 

 

• Voeg bovenin de \Pages\XML\Delete.cshtml pagina de volgende code toe: 
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\Pages\XML\Index.cshtml pagina gereed maken voor gebruik 

 

• Pas het bestand \Pages\XML\Index.cshtml aan door op regel 25 een kolom toe te voegen voor de 

verwijder links. Daarna voeg je regel 38 toe om per muzieknummer een verwijder link te maken. Bij 

de verwijder link bouwen we de URL op met een id parameter. Deze parameter nemen we op zodat 

we de verwijder actie kunnen uitvoeren specifiek voor een gekozen muzieknummer met dat id. 
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De class SongMethods aanpassen 

• Maak een nieuwe methode in de class SongMethods aan met de naam DeleteSong(…). Deze 

methode heeft twee parameters. De methode heeft de volgende twee parameters: file (die zijn we 

al tegengekomen bij de methode CreateSong) en id. Deze laatste is het id van het muzieknummer 

die verwijderd moet worden. 

 

In de code wordt gebruik gemaakt van de methode Select van de collection Tables. Deze methode gebruiken 

we om op zoek te gaan naar een muzieknummer met een specifieke waarde voor de id kolom. Als de 

DataRow met het juiste id gevonden wordt, dan wordt deze opgeslagen in een array drSongs. Mochten er 

muzieknummers zijn gevonden dan wordt het eerste element van die drSongs array verwijderd en daarna 

worden de gegevens in de DataSet opgeslagen (lees: overschreven) in het XML bestand. 

 

\Pages\XML\Delete.cshtml pagina gereed maken voor gebruik 
Tot slot moeten we de pagina \Pages\XML\Delete.cshtml weer aanpassen. 

• Voeg nu het volgende stuk code toe aan het C# code blok op deze pagina. 

 

Als het formulier gepost is, dan wordt eerst nagegaan of de radiobutton met value="ja" is geselecteerd. Let 

er wel op dat in jouw gemaakte HTML formulier dan radiobuttons moeten zijn opgenomen met de naam 

inputOptie en één van deze twee radiobuttons moet als value Ja hebben. 

In de regel string id = Request.Query["id"]; wordt de waarde van de parameter id in de url gelezen en in de 

variabele id geplaatst. De code Request.Query["id"] is te vergelijken met $_GET["id"] in PHP.  
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Een muzieknummer wijzigen in de playlist 
De volgende stap is het wijzigen van een muzieknummer, maar hier ontvang je geen stappenplan voor. Er is 

een combinatie benodigd van het zoeken naar een correct muzieknummer (zoals bij verwijderen gedaan is) 

en het aanbrengen van wijzigingen in een muzieknummer middels een formulier op een cshtml pagina. 

 

Een eerste blik op JSON en YAML 
Wanneer je klaar bent met de XML variant van de music playlist dien je de webapplicatie uit te breiden met 

een JSON (en wellicht zelfs een YAML) playlist. Via de volgende link is een eerste blik mogelijk hoe JSON en 

YAML er ongeveer uit zien en wat de verschillen zijn t.o.v. XML: 

http://sangsoonam.github.io/2017/03/13/yaml-vs-json.html. 

Om gebruik te maken van JSON is het aan te raden om te werken met Newtonsoft. Wanneer je begint met 

het toevoegen van een JSON music playlist zoek dan op Google op termen als C# JSON Newtonsoft. 

Om YAML toe te passen is het gebruik van de library genaamd YamlDotNet een aanrader. 

http://sangsoonam.github.io/2017/03/13/yaml-vs-json.html

